tomCAt7支持jDk1.8吗

支持,看看你的类是不是在1.7的java环境编译的,还有看看你的tomcat使用的jre是不是1.8的,是不是装了多个不同版本的jre,可能是tomcat引入的jre和jdk的不一样

你说反了,而应该问jdk1.8支持tomcat7吗?tomcat底层运行的就是java的Socket,也就是说tomcat是在jdk环境下运行的。而且这也不是问题,tomcat本来就是用java语言写的,java版本高1.8肯定支持tomcat7了,好像tomcat7在某个版本(7.0.72,具体记不...

支持,看看你的类是不是在1.7的java环境编译的,还有看看你的tomcat使用的jre是不是1.8的,是不是装了多个不同版本的jre,可能是tomcat引入的jre和jdk的不一样

支持,看看你的类是不是在1.7的java环境编译的,还有看看你的tomcat使用的jre是不是1.8的,是不是装了多个不同版本的jre,可能是tomcat引入的jre和jdk的不一样

支持,但是你用这么高版本做什么,高版本可能会舍弃一部分旧特性,导致编译时出现莫名其妙的错误,还是推荐tomcat6.0+jdk1.6

支持"、、、

你好。 根据你的描述: jdk版本的设计是向后兼容的,即高版本支持低版本,所以tomcat6支持jdk1.8的。

从官方版本说明来看,jdk1.8跟Tomcat 7应该是兼容的,如图: 原链接:http://tomcat.apache.org/whichversion.html

你说反了,而应该问jdk1.8支持tomcat7吗?tomcat底层运行的就是java的Socket,也就是说tomcat是在jdk环境下运行的。而且这也不是问题,tomcat本来就是用java语言写的,java版本高1.8肯定支持tomcat7了,好像tomcat7在某个版本(7.0.7

建议使用JDK1.6或者1.7,1.5有点旧了,1.8又太新了

相关文档

jdk1.8不兼容tomcat7吗?
tomcat7支持jdk1.8吗
jdk1.8 和tomcat 7 不兼容么
我装了1.8的jdk和tomcat7,为什么不能兼容呢?jdk...
tomcat7.x支持jdk1.8吗
tomcat7.x支持jdk1.8吗
tomcat7.x支持jdk1.8吗
jdk1.8 和tomcat 7 不兼容么
tomcat7.x支持jdk1.8吗
tomcat7需要jdk的哪个版本支持
电脑版